aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a597f3fc12..49d406cc99 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -68,6 +68,7 @@
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2020 Sebastian Schott <sschott@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -167,6 +168,24 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-easygui
+ (package
+ (name "python-easygui")
+ (version "0.98.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "easygui" version))
+ (sha256
+ (base32
+ "1zmvmwgxyzvm83818skhn8b4wrci4kmnixaax8q3ia5cn7xrmj6v"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-tkinter" ,python "tk")))
+ (home-page "https://github.com/robertlugg/easygui")
+ (synopsis "GUI programming module for Python")
+ (description "EasyGUI is a module for very simple, very easy GUI programming in Python. EasyGUI is different from other GUI generators in that EasyGUI is NOT event-driven. Instead, all GUI interactions are invoked by simple function calls.")
+ (license license:bsd-3)))
+
(define-public python-pymediainfo
(package
(name "python-pymediainfo")