aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7a4f11b4b8..a5da46dfdb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10858,6 +10858,37 @@ cases.")
(define-public python2-ddt
(package-with-python2 python-ddt))
+(define-public python-pycountry
+ (package
+ (name "python-pycountry")
+ (version "18.5.26")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pycountry" version))
+ (sha256
+ (base32
+ "15q9j047s3yc9cfcxq1ch8b71f81na44cr6dydd5gxk0ki9a4akz"))))
+ (build-system python-build-system)
+ (home-page "https://bitbucket.org/flyingcircus/pycountry")
+ (synopsis "ISO databases for languages, countries, currencies, etc.")
+ (description
+ "@code{pycountry} provides the ISO databases for the standards:
+@enumerate
+@item 639-3 (Languages)
+@item 3166 (Countries)
+@item 3166-3 (Deleted Countries)
+@item 3166-2 (Subdivisions of countries)
+@item 4217 (Currencies)
+@item 15924 (Scripts)
+@end enumerate
+It includes a copy from Debian’s pkg-isocodes and makes the data accessible
+through a Python API.")
+ (license license:lgpl2.1+)))
+
+(define-public python2-pycountry
+ (package-with-python2 python-pycountry))
+
(define-public python-pycosat
(package
(name "python-pycosat")