aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/terminals.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 0f11fa650a..2d15d77524 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -240,9 +240,10 @@ compatibility to existing emulators like xterm, gnome-terminal, konsole, etc.")
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'autogen.sh
+ (replace 'bootstrap
(lambda _
- (zero? (system* "sh" "autogen.sh"))))
+ (setenv "NOCONFIGURE" "indeed")
+ (invoke "sh" "autogen.sh")))
;; Use elogind instead of systemd.
(add-before 'configure 'remove-systemd
(lambda _