aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f76f59f972..3efdad30fd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -909,6 +909,28 @@ multiple Unicode code points, e.g. \"G\" + acute-accent)
(define-public python2-uniseg
(package-with-python2 python-uniseg))
+(define-public python-ujson
+ (package
+ (name "python-ujson")
+ (version "1.35")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ujson" version))
+ (sha256
+ (base32
+ "11jz5wi7mbgqcsz52iqhpyykiaasila4lq8cmc2d54bfa3jp6q7n"))))
+ (build-system python-build-system)
+ (home-page "http://www.esn.me")
+ (synopsis
+ "Ultra fast JSON encoder and decoder for Python")
+ (description
+ "Ultra fast JSON encoder and decoder for Python")
+ (license license:bsd-3)))
+
+(define-public python2-ujson
+ (package-with-python2 python-ujson))
+
(define-public python-humanfriendly
(package
(name "python-humanfriendly")