aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 21d1ccc993..9c675f928d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8072,6 +8072,30 @@ document.")
(define-public python2-jmespath
(package-with-python2 python-jmespath))
+(define-public python-boto
+ (package
+ (name "python-boto")
+ (version "2.48.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "boto" version))
+ (sha256
+ (base32
+ "1l80f1njpdkvzvs6z4abixskhqwr31h8arfywdwrc42bfddr5f6y"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/boto/boto/")
+ (synopsis "Amazon Web Services Library")
+ (description "Amazon Web Services Library")
+ (license license:expat)))
+
+(define-public python2-boto
+ (package-with-python2 python-boto))
+
(define-public python-botocore
(package
(name "python-botocore")