aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index bec1fc47c9..df5753dfac 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6212,6 +6212,32 @@ Unicode-aware. It is not intended as an end-user tool.")
(define-public python2-xlrd
(package-with-python2 python-xlrd))
+(define-public python-preshed
+ (package
+ (name "python-preshed")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "preshed" version))
+ (sha256
+ (base32
+ "1pdl4p2d32ficfh18xdkgsj6ajzdxc6mxhhf84z0wq1l8viskcx6"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-cymem" ,python-cymem)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest-3.0)))
+ (home-page "https://github.com/spacy-io/preshed")
+ (synopsis
+ "Cython hash table that trusts the keys are pre-hashed")
+ (description
+ "Cython hash table that trusts the keys are pre-hashed")
+ (license license:expat)))
+
+(define-public python2-preshed
+ (package-with-python2 python-preshed))
+
(define-public python-prettytable
(package
(name "python-prettytable")