aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9c675f928d..8248f61138 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12548,6 +12548,33 @@ many of the popular cloud service providers using a unified API.")
(define-public python2-apache-libcloud
(package-with-python2 python-apache-libcloud))
+(define-public python-smart-open
+(package
+ (name "python-smart-open")
+ (version "1.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "smart_open" version))
+ (sha256
+ (base32
+ "0m5j71f7f36s17v4mwv0bxg4azknvcy82rbjp28b4vifrjd6dm7s"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-boto" ,python-boto)))
+ (home-page
+ "https://github.com/piskvorky/smart_open")
+ (synopsis
+ "Utils for streaming large files (S3, HDFS, gzip, bz2...)")
+ (description
+ "Utils for streaming large files (S3, HDFS, gzip, bz2...)")
+ (license license:expat)))
+
+(define-public python2-smart-open
+ (package-with-python2 python-smart-open))
+
(define-public python-smmap2
(package
(name "python-smmap2")