aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4f52e76b0d..a8154e18c3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -827,6 +827,29 @@ API for locking files.")
(define-public python2-lockfile
(package-with-python2 python-lockfile))
+(define-public python2-selectors34
+ (package
+ (name "python2-selectors34")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "selectors34" version))
+ (sha256
+ (base32
+ "0725hqbbfjw9aicmfydz21ya29wsz1rph9iz4fsnz9zq6xihdx89"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (propagated-inputs `(("python2-six" ,python2-six)))
+ (home-page
+ "https://github.com/berkerpeksag/selectors34")
+ (synopsis
+ "Backport of the selectors module from Python 3.4.")
+ (description
+ "Backport of the selectors module from Python 3.4.")
+ (license #f)))
+
(define-public python-setuptools
(package
(name "python-setuptools")