aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 33b397e78d..d27f4b4e76 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2617,6 +2617,33 @@ which can produce feeds in RSS 2.0, RSS 0.91, and Atom formats.")
(define-public python2-feedgenerator
(package-with-python2 python-feedgenerator))
+(define-public python-ftfy
+ (package
+ (name "python-ftfy")
+ (version "5.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ftfy" version))
+ (sha256
+ (base32
+ "0y4yqagn0n64n6bfwcsi8m0d17j99x70i9x0v31awwjzmlprm8k7"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-wcwidth" ,python-wcwidth)))
+ (home-page
+ "http://github.com/LuminosoInsight/python-ftfy")
+ (synopsis
+ "Fixes some problems with Unicode text after the fact")
+ (description
+ "Fixes some problems with Unicode text after the fact")
+ (license license:expat)))
+
+(define-public python2-ftfy
+ (package-with-python2 python-ftfy))
+
(define-public python-blinker
(package
(name "python-blinker")