aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b6c05b1a29..5f985d3607 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3962,6 +3962,29 @@ by pycodestyle.")
(define-public python2-autopep8
(package-with-python2 python-autopep8))
+(define-public python-dill
+ (package
+ (name "python-dill")
+ (version "0.2.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dill" version))
+ (sha256
+ (base32
+ "0wqg8mfny9ynvw2yrz6bray7d1zzzkn1i0zc24mx8hp7by7pbzcp"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (home-page
+ "http://www.cacr.caltech.edu/~mmckerns/dill.htm")
+ (synopsis "serialize all of python")
+ (description "serialize all of python")
+ (license #f)))
+
+(define-public python2-dill
+ (package-with-python2 python-dill))
+
(define-public python-distutils-extra
(package
(name "python-distutils-extra")