aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d27f4b4e76..08207247d0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2094,6 +2094,30 @@ easier to build concurrent applications.")
(define-public python2-pykka
(package-with-python2 python-pykka))
+(define-public python-ijson
+ (package
+ (name "python-ijson")
+ (version "2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ijson" version))
+ (sha256
+ (base32
+ "0x7l9k2dvxzd5mjgiq15nl9b0sxcqy1cqaz744bjwkz4z5mrypzg"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (home-page "https://github.com/isagalaev/ijson")
+ (synopsis
+ "Iterative JSON parser with a standard Python iterator interface")
+ (description
+ "Iterative JSON parser with a standard Python iterator interface")
+ (license license:bsd-3)))
+
+(define-public python2-ijson
+ (package-with-python2 python-ijson))
+
(define-public python-itsdangerous
(package
(name "python-itsdangerous")