aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f694de6749..666d8fea9d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4439,6 +4439,33 @@ away.")
(define-public python2-ipython-genutils
(package-with-python2 python-ipython-genutils))
+(define-public python-toolz
+ (package
+ (name "python-toolz")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "toolz" version))
+ (sha256
+ (base32
+ "0l3czks4xy37i8099waxk2fdz5g0k1dwys2mkhlxc0b0886cj4sa"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (home-page "https://github.com/pytoolz/toolz/")
+ (synopsis
+ "Toolz provides list processing tools and functional utilities")
+ (description
+ "Toolz provides a set of utility functions for iterators, functions, and
+dictionaries. They extend the standard libraries itertools and functools and
+borrow heavily from the standard libraries of contemporary functional
+languages.")
+ (license license:bsd-3)))
+
+(define-public python2-toolz
+ (package-with-python2 python-toolz))
+
(define-public python-traitlets
(package
(name "python-traitlets")