aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 4f5a67093c..6fb323deaf 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -313,6 +313,38 @@ languages.")
(variable "INFOPATH")
(files '("share/info"))))))))
+(define-public emacs-next-pgtk
+ (let ((commit "3df4ca451d41a5f1036713277ef55ca9734c6fa7")
+ (revision "0"))
+ (package/inherit emacs-next
+ (name "emacs-next-pgtk")
+ (version (git-version "28.0.50" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/masm11/emacs")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c677c97b9avhlzysg09cvf6bd69iz41ggppnszw8chhphk3knfc"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments emacs-next)
+ ((#:configure-flags flags ''())
+ `(cons* "--with-pgtk" "--with-xwidgets" ,flags))))
+ (propagated-inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("glib-networking" ,glib-networking)))
+ (inputs
+ `(("webkitgtk" ,webkitgtk)
+ ,@(package-inputs emacs-next)))
+ (home-page "https://github.com/masm11/emacs")
+ (synopsis "Emacs text editor with @code{pgtk} and @code{xwidgets} support")
+ (description "This is an unofficial Emacs fork build with a pure-GTK
+graphical toolkit to work natively on Wayland. In addition to that, xwidgets
+also enabled and works without glitches even on X server."))))
+
(define-public emacs-minimal
;; This is the version that you should use as an input to packages that just
;; need to byte-compile .el files.