aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ftp.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index c79991e3af..5d07052b39 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -270,7 +270,8 @@ directory comparison and more.")
(build-system gnu-build-system)
(arguments
`(#:make-flags
- (list "LDFLAGS=-lcap -lcrypt -lpam")
+ (list "LDFLAGS=-lcap -lcrypt -lpam"
+ "INSTALL=install -D")
#:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
@@ -284,17 +285,7 @@ directory comparison and more.")
(add-after 'unpack 'patch-installation-directory
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "Makefile"
- (("/usr") (assoc-ref outputs "out")))
- #t))
- (add-before 'install 'mkdir
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (mkdir-p out)
- (mkdir (string-append out "/sbin"))
- (mkdir (string-append out "/man"))
- (mkdir (string-append out "/man/man5"))
- (mkdir (string-append out "/man/man8"))
- #t)))
+ (("/usr") (assoc-ref outputs "out")))))
(delete 'configure)))) ; no configure script
(inputs
`(("libcap" ,libcap)