aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 788148f32b..b3c6d9821e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13222,6 +13222,11 @@ approach.")
"--ignore=tests/test_google_lifesciences.py")
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'tabulate-compatibility
+ (lambda _
+ (substitute* "snakemake/dag.py"
+ (("\"job\": rule,")
+ "\"job\": rule.name,"))))
;; For cluster execution Snakemake will call Python. Since there is
;; no suitable PYTHONPATH set, cluster execution will fail. We fix
;; this by calling the snakemake wrapper instead.