aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/qt.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index e02e7fbfc3..4a0c91b482 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2022, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Herman Rimm <herman@rimm.ee>
;;; Copyright © 2024 Foundation Devices, Inc. <hello@foundation.xyz>
+;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -268,6 +269,43 @@ window managers, that don't provide Qt integration by themselves.")
(home-page "https://qt5ct.sourceforge.io/")
(license license:bsd-2)))
+(define-public qt6ct
+ (package
+ (name "qt6ct")
+ (version "0.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/trialuser02/qt6ct")
+ (commit version)))
+ (sha256
+ (base32 "0dknk4qqzqc5wa763nclb1k6jkmvjh8kzz8kfp4iggy9jy0vnzgb"))))
+ (build-system qt-build-system)
+ (arguments
+ (list
+ #:qtbase qtbase
+ #:tests? #f ; No target
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* '("src/qt6ct-qtplugin/CMakeLists.txt"
+ "src/qt6ct-style/CMakeLists.txt")
+ (("\\$\\{PLUGINDIR\\}")
+ (string-append #$output "/lib/qt6/plugins"))))))))
+ (native-inputs
+ (list qttools))
+ (inputs
+ (list qtsvg
+ libxkbcommon))
+ (synopsis "Qt6 Configuration Tool")
+ (description "Qt6CT is a program that allows users to configure Qt6
+settings (such as icons, themes, and fonts) in desktop environments or
+window managers, that don't provide Qt integration by themselves.")
+ (home-page "https://github.com/trialuser02/qt6ct")
+ (license license:bsd-2)))
+
(define-public kddockwidgets
(package
(name "kddockwidgets")