aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 18b6f8139f..8c074d0276 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5457,6 +5457,34 @@ slices (@code{.find()}, @code{RevSlice}), strings and other things.
Things in odds may move to more appropriate crates if we find them.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-once-cell-1.2
+ (package
+ (name "rust-once-cell")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "once-cell" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vdz8xlg3r05w3wfjimnc347hgm54i5nrqf72r4mlp0fcdplh7w9"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-parking-lot" ,rust-parking-lot-0.9))
+ #:cargo-development-inputs
+ (("rust-crossbeam-utils" ,rust-crossbeam-utils-0.6)
+ ("rust-lazy-static" ,rust-lazy-static-1.3)
+ ("rust-regex" ,rust-regex-1.1))))
+ (home-page "https://github.com/matklad/once_cell")
+ (synopsis "Single assignment cells and lazy values")
+ (description
+ "Single assignment cells and lazy values.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-opaque-debug-0.2
(package
(name "rust-opaque-debug")