aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 0 insertions, 17 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8f8758ed59..5169877b46 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1665,7 +1665,6 @@ GNU CC attributes. It provides also a C pretty printer as an example of use.")
(list ocaml-alcotest ocaml-ounit ocaml-ppxlib))
(native-inputs
(list ocamlbuild))
- (properties `((ocaml4.07-variant . ,(delay ocaml4.07-qcheck))))
(home-page "https://github.com/c-cube/qcheck")
(synopsis "QuickCheck inspired property-based testing for OCaml")
(description "QuickCheck inspired property-based testing for OCaml. This
@@ -1674,22 +1673,6 @@ generated instances of the type. It provides combinators for generating
instances and printing them.")
(license license:lgpl3+)))
-(define-public ocaml4.07-qcheck
- (package-with-ocaml4.07
- (package
- (inherit ocaml-qcheck)
- (version "0.12")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/c-cube/qcheck")
- (commit version)))
- (file-name (git-file-name "ocaml-qcheck" version))
- (sha256
- (base32
- "1llnfynhlndwyjig7wrayjnds2b3mggp5lw20dwxhn2i2lkkb22m"))))
- (properties '()))))
-
(define-public ocaml-qtest
(package
(name "ocaml-qtest")