aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gstreamer.scm5
-rw-r--r--gnu/packages/patches/orc-typedef-enum.patch17
3 files changed, 2 insertions, 21 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a76f222abd..21102514a9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1212,7 +1212,6 @@ dist_patch_DATA = \
%D%/packages/patches/openssl-c-rehash-in.patch \
%D%/packages/patches/openssl-CVE-2019-1559.patch \
%D%/packages/patches/open-zwave-hidapi.patch \
- %D%/packages/patches/orc-typedef-enum.patch \
%D%/packages/patches/orpheus-cast-errors-and-includes.patch \
%D%/packages/patches/osip-CVE-2017-7853.patch \
%D%/packages/patches/ots-no-include-missing-file.patch \
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 51b9d8f11c..bed9e36ce6 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -69,15 +69,14 @@
(define-public orc
(package
(name "orc")
- (version "0.4.30")
+ (version "0.4.31")
(source (origin
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/data/src/"
"orc/orc-" version ".tar.xz"))
- (patches (search-patches "orc-typedef-enum.patch"))
(sha256
(base32
- "0wj93im7i8a6546q2r8sp39yjfbxflkc0ygb0b8iqsd58qhvjhds"))))
+ "0xb0c7q3xv1ldmz5ipybazb01gy3cijj8622dcx7rbm9lq85zax0"))))
(build-system meson-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/patches/orc-typedef-enum.patch b/gnu/packages/patches/orc-typedef-enum.patch
deleted file mode 100644
index 207bf32ba9..0000000000
--- a/gnu/packages/patches/orc-typedef-enum.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Orc 0.4.30 has a bug that causes duplicate symbols due to a missing typedef.
-
-Taken from upstream:
-https://gitlab.freedesktop.org/gstreamer/orc/merge_requests/32
-
-diff --git a/orc/orctarget.h b/orc/orctarget.h
---- a/orc/orctarget.h
-+++ b/orc/orctarget.h
-@@ -19,7 +19,7 @@ enum {
- ORC_TARGET_FAST_DENORMAL = (1<<31)
- };
-
--enum {
-+typedef enum {
- ORC_TARGET_POWERPC_64BIT = (1<<0),
- ORC_TARGET_POWERPC_LE = (1<<1),
- ORC_TARGET_POWERPC_ALTIVEC = (1<<2),