aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b41e0c61b8..3907fd66bd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -341,6 +341,15 @@ data types.")
;; Current 2.x version.
(define-public python-2 python-2.7)
+(define-public python2-called-python
+ ;; Both 2.x and 3.x used to be called "python". In commit
+ ;; a7714d42de2c3082f3609d1e63c83d703fb39cf9 (March 2018), we renamed the
+ ;; Python 2.x package to "python2".
+ (package
+ (inherit python-2)
+ (name "python")
+ (properties `((superseded . ,python-2)))))
+
(define-public python-3.6
(package (inherit python-2)
(name "python")