aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cups.scm8
-rw-r--r--gnu/packages/pdf.scm17
2 files changed, 3 insertions, 22 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 39ab41c192..94f8e91f17 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -52,7 +52,6 @@
(define-public cups-filters
(package
(name "cups-filters")
- (replacement cups-filters/fixed)
(version "1.13.1")
(source(origin
(method url-fetch)
@@ -135,13 +134,6 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
license:lgpl2.0+
license:expat))))
-(define mupdf/fixed-instead-of-mupdf
- (package-input-rewriting `((,mupdf . ,(@@ (gnu packages pdf) mupdf/fixed)))))
-
-;;; Fix CVE-2016-10132 and CVE-2016-10133. See mupdf/fixed for more information.
-(define cups-filters/fixed
- (mupdf/fixed-instead-of-mupdf cups-filters))
-
;; CUPS on non-MacOS systems requires cups-filters. Since cups-filters also
;; depends on CUPS libraries and binaries, cups-minimal has been added to
;; satisfy this dependency.
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 2ea48e5999..d449b72eef 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -481,7 +481,6 @@ extracting content or merging files.")
(define-public mupdf
(package
(name "mupdf")
- (replacement mupdf/fixed)
(version "1.10a")
(source
(origin
@@ -491,7 +490,9 @@ extracting content or merging files.")
(sha256
(base32
"0dm8wcs8i29aibzkqkrn8kcnk4q0kd1v66pg48h5c3qqp4v1zk5a"))
- (patches (search-patches "mupdf-build-with-openjpeg-2.1.patch"))
+ (patches (search-patches "mupdf-build-with-openjpeg-2.1.patch"
+ "mupdf-mujs-CVE-2016-10132.patch"
+ "mupdf-mujs-CVE-2016-10133.patch"))
(modules '((guix build utils)))
(snippet
;; Delete all the bundled libraries except for mujs, which is
@@ -540,18 +541,6 @@ line tools for batch rendering (pdfdraw), rewriting files (pdfclean),
and examining the file structure (pdfshow).")
(license license:agpl3+)))
-(define mupdf/fixed
- (package
- (inherit mupdf)
- (source
- (origin
- (inherit (package-source mupdf))
- (patches
- (append
- (origin-patches (package-source mupdf))
- (search-patches "mupdf-mujs-CVE-2016-10132.patch"
- "mupdf-mujs-CVE-2016-10133.patch")))))))
-
(define-public qpdf
(package
(name "qpdf")