aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 30f1610c1d..636b485260 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1037,10 +1037,13 @@ Swath).")
`(("mpi" ,openmpi)
,@(package-inputs hdf5)))
(arguments
- (substitute-keyword-arguments `(#:configure-flags '("--enable-parallel")
- ,@(package-arguments hdf5))
+ (substitute-keyword-arguments (package-arguments hdf5)
+ ((#:configure-flags flags)
+ ``("--enable-parallel" ,@(delete "--enable-cxx" ,flags)))
((#:phases phases)
`(modify-phases ,phases
+ (add-after 'build 'mpi-setup
+ ,%openmpi-setup)
(add-before 'check 'patch-tests
(lambda _
;; OpenMPI's mpirun will exit with non-zero status if it