aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/web.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 08485cadb2..3a3311003f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -230,7 +230,8 @@ Interface} specification.")
(setenv "CC" "gcc")
(format #t "environment variable `CC' set to `gcc'~%")
(format #t "configure flags: ~s~%" flags)
- (zero? (apply system* "./configure" flags)))))
+ (apply invoke "./configure" flags)
+ #t)))
(add-after 'install 'install-man-page
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -251,7 +252,8 @@ Interface} specification.")
(rename-file (string-append out "/conf")
(string-append share "/conf"))
(rename-file (string-append out "/html")
- (string-append share "/html"))))))))
+ (string-append share "/html"))
+ #t))))))
(home-page "https://nginx.org")
(synopsis "HTTP and reverse proxy server")
(description
@@ -343,7 +345,8 @@ documentation.")
(("#banner \\{ background: black;")
"#banner { background: black;
display: none;"))
- (zero? (system* "make")))))
+ (invoke "make")
+ #t)))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((output (assoc-ref outputs "out")))