aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/xdisorg.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 4d1dc8391c..6b4d3f4a8a 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -965,7 +965,14 @@ transparent text on your screen.")
(substitute* "xbindkeys_show"
(("^#!.*|^exec wish.*") "")
(("^# \\\\") (string-append "#!" (which "wish"))))
- #t)))))
+ #t))
+ (add-after 'unpack 'patch-references
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "xbindkeys_show"
+ (("\"(xbindkeys)\"" _ command)
+ (format #f "\"~a/bin/~a\"" out command)))
+ #t))))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs