aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e052a3797c..a43f0975f4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6877,6 +6877,31 @@ pairs in insertion order.")
("rust-serde" ,rust-serde-0.8)
("rust-serde-test" ,rust-serde-test-0.8))))))
+(define-public rust-lscolors-0.6
+ (package
+ (name "rust-lscolors")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lscolors" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jxsgkn378kxkiqdshdjdclw5wwp2xaz45cqd3yw85fhn8a38fza"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-ansi-term" ,rust-ansi-term-0.12))
+ #:cargo-development-inputs
+ (("rust-tempfile" ,rust-tempfile-3.1))))
+ (home-page "https://github.com/sharkdp/lscolors")
+ (synopsis "Colorize paths using the LS_COLORS environment variable")
+ (description
+ "Colorize paths using the LS_COLORS environment variable.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-new-debug-unreachable-1.0
(package
(name "rust-new-debug-unreachable")