aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/mail.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6721b5e4ee..4a9c6fc90f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1453,7 +1453,6 @@ facilities for checking incoming mail.")
(arguments
`(#:configure-flags '("--sysconfdir=/etc"
"--localstatedir=/var"
- "--with-moduledir=/etc/dovecot/modules"
"--with-sqlite" ; not auto-detected
"--with-lucene") ; not auto-detected
#:phases
@@ -1472,13 +1471,9 @@ facilities for checking incoming mail.")
(("cat") (which "cat")))
#t))
(replace 'install
- (lambda* (#:key outputs make-flags #:allow-other-keys)
- ;; The .la files don't like having the moduledir moved.
- (for-each delete-file (find-files "." "\\.la"))
+ (lambda* (#:key make-flags #:allow-other-keys)
;; Simple hack to avoid installing a trivial README in /etc.
(apply invoke "make" "install" "sysconfdir=/tmp/bogus"
- (string-append "moduledir=" (assoc-ref outputs "out")
- "/lib/dovecot")
make-flags))))))
(home-page "https://www.dovecot.org")
(synopsis "Secure POP3/IMAP server")