aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/music.scm8
-rw-r--r--gnu/packages/patches/picard-fix-id3-rename-test.patch11
3 files changed, 17 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e5bebd9a48..979339e5b8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1429,6 +1429,7 @@ dist_patch_DATA = \
%D%/packages/patches/perl-module-pluggable-search.patch \
%D%/packages/patches/perl-reproducible-build-date.patch \
%D%/packages/patches/perl-www-curl-remove-symbol.patch \
+ %D%/packages/patches/picard-fix-id3-rename-test.patch \
%D%/packages/patches/picprog-non-intel-support.patch \
%D%/packages/patches/pidgin-add-search-path.patch \
%D%/packages/patches/pidgin-libnm.patch \
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 068a775005..879d90b241 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2916,7 +2916,7 @@ event-based scripts for scrobbling, notifications, etc.")
(define-public picard
(package
(name "picard")
- (version "2.1.3")
+ (version "2.4.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2924,7 +2924,8 @@ event-based scripts for scrobbling, notifications, etc.")
"picard/picard-" version ".tar.gz"))
(sha256
(base32
- "19w5k3bf4886gdycxjds9nkjvir0gwy2r5cqkz0lbls4ikk4y14f"))))
+ "1c5l7i43jaj3s4wklc0cba6nn2x9cmpcggk4q4h9m1bci2xilsiy"))
+ (patches (search-patches "picard-fix-id3-rename-test.patch"))))
(build-system python-build-system)
(arguments
'(#:use-setuptools? #f
@@ -2943,7 +2944,8 @@ event-based scripts for scrobbling, notifications, etc.")
(assoc-ref inputs "chromaprint") "/bin/fpcalc")))
#t)))))
(native-inputs
- `(("gettext" ,gettext-minimal)))
+ `(("gettext" ,gettext-minimal)
+ ("python-dateutil" ,python-dateutil)))
(inputs
`(("chromaprint" ,chromaprint)
("python-discid" ,python-discid)
diff --git a/gnu/packages/patches/picard-fix-id3-rename-test.patch b/gnu/packages/patches/picard-fix-id3-rename-test.patch
new file mode 100644
index 0000000000..3c4fa63c84
--- /dev/null
+++ b/gnu/packages/patches/picard-fix-id3-rename-test.patch
@@ -0,0 +1,11 @@
+Index: b/test/formats/test_id3.py
+===================================================================
+--- a/test/formats/test_id3.py
++++ b/test/formats/test_id3.py
+@@ -266,5 +266,5 @@
+ def test_rename_txxx_tags(self):
+ file_path = os.path.join('test', 'data', 'test-id3-rename-tags.mp3')
+- filename = self.copy_file_tmp(file_path, 'mp3')
++ filename = self.copy_file_tmp(file_path, '.mp3')
+ raw_metadata = load_raw(filename)
+ self.assertIn('TXXX:Artists', raw_metadata)