aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d932c3583a..021e972a89 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1033,6 +1033,27 @@ It has been modified to remove all non-free binary blobs.")
("CONFIG_AXP20X_ADC" . m))
%default-extra-linux-options)))
+(define-public linux-libre-arm64-generic-5.10
+ (make-linux-libre* linux-libre-5.10-version
+ linux-libre-5.10-source
+ '("aarch64-linux")
+ #:defconfig "defconfig"
+ #:extra-version "arm64-generic"
+ #:extra-options
+ (append
+ `(;; needed to fix the RTC on rockchip platforms
+ ("CONFIG_RTC_DRV_RK808" . #t)
+ ;; Pinebook display, battery, charger and usb
+ ("CONFIG_DRM_ANALOGIX_ANX6345" . m)
+ ("CONFIG_CHARGER_AXP20X" . m)
+ ("CONFIG_INPUT_AXP20X_PEK" . m)
+ ("CONFIG_CHARGER_AXP20X" . m)
+ ("CONFIG_BATTERY_AXP20X" . m)
+ ("CONFIG_PINCTRL_AXP209" . m)
+ ("CONFIG_AXP20X_POWER" . m)
+ ("CONFIG_AXP20X_ADC" . m))
+ %default-extra-linux-options)))
+
(define-public linux-libre-arm64-generic-5.4
(make-linux-libre* linux-libre-5.4-version
linux-libre-5.4-source