aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/logging.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 6a4975e435..bf2ebde712 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -206,7 +207,10 @@ output in multiple windows in a terminal.")
(arguments
'(#:configure-flags
(list "-DSPDLOG_BUILD_BENCH=OFF"
- "-DSPDLOG_BUILD_TESTS=ON")))
+ "-DSPDLOG_BUILD_TESTS=ON"
+ "-DSPDLOG_FMT_EXTERNAL=ON")))
+ (propagated-inputs
+ `(("fmt" ,fmt))) ; Required from the pkg-config file
(home-page "https://github.com/gabime/spdlog")
(synopsis "Fast C++ logging library")
(description "Spdlog is a very fast header-only/compiled C++ logging