aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-build.scm21
-rw-r--r--gnu/packages/python-xyz.scm21
2 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 7572bc5ce3..716108df2b 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -41,6 +41,27 @@
;;;
;;; Code:
+(define-public python-pip
+ (package
+ (name "python-pip")
+ (version "22.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pip" version))
+ (sha256
+ (base32
+ "0jwac0bhfp48w4fqibf1ysrs2grksdv92hwqm7bmdw2jn2fr5l9z"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; there are no tests in the pypi archive.
+ (home-page "https://pip.pypa.io/")
+ (synopsis "Package manager for Python software")
+ (description
+ "Pip is a package manager for Python software, that finds packages on the
+Python Package Index (PyPI).")
+ (license license:expat)))
+
(define-public python-setuptools
(package
(name "python-setuptools")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 27dbbd831d..75b99086d0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12835,27 +12835,6 @@ fakes, or doubles. Basically, a stub is an object that returns pre-canned
responses, rather than doing any computation.")
(license license:bsd-3)))
-(define-public python-pip
- (package
- (name "python-pip")
- (version "22.2.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pip" version))
- (sha256
- (base32
- "0jwac0bhfp48w4fqibf1ysrs2grksdv92hwqm7bmdw2jn2fr5l9z"))))
- (build-system python-build-system)
- (arguments
- '(#:tests? #f)) ; there are no tests in the pypi archive.
- (home-page "https://pip.pypa.io/")
- (synopsis "Package manager for Python software")
- (description
- "Pip is a package manager for Python software, that finds packages on the
-Python Package Index (PyPI).")
- (license license:expat)))
-
;;; Variant used to break a dependency cycle with
;;; python-pytest-perf-bootstrap.
(define-public python-pip-run-bootstrap