aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/patchutils.scm6
-rw-r--r--gnu/services/web.scm19
2 files changed, 6 insertions, 19 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 818934189d..ebf3bee0fe 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -460,6 +460,12 @@ application = get_wsgi_application()\n") port)))))
;; running Django applications.
(let ((static-root
(string-append out "/share/patchwork/htdocs")))
+ (substitute* (string-append
+ out-site-packages
+ "/patchwork/settings/base.py")
+ (("os\\.path\\.join\\(ROOT\\_DIR, 'htdocs'\\)")
+ (string-append "'" static-root "'")))
+
(mkdir-p static-root)
(copy-file "patchwork/settings/production.example.py"
"patchwork/settings/assets.py")
diff --git a/gnu/services/web.scm b/gnu/services/web.scm
index c2d8ebbddf..721f28c257 100644
--- a/gnu/services/web.scm
+++ b/gnu/services/web.scm
@@ -1790,25 +1790,6 @@ ENABLE_XMLRPC = " #$(if enable-xmlrpc? "True" "False") "
FORCE_HTTPS_LINKS = " #$(if force-https-links? "True" "False") "
-LOGGING = {
- 'version': 1,
- 'disable_existing_loggers': False,
- 'handlers': {
- 'file': {
- 'level': 'DEBUG',
- 'class': 'logging.FileHandler',
- 'filename': '/var/log/patchwork/debug.log',
- },
- },
- 'loggers': {
- 'django': {
- 'handlers': ['file'],
- 'level': 'DEBUG',
- 'propagate': True,
- },
- },
-}
-
DATABASES = {
'default': {
" #$(match database-configuration