aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/graphics.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index d9e0b5b859..3f6e7d64a5 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1181,13 +1181,15 @@ with strong support for multi-part, multi-channel use cases.")
#t))
,@(if (not (target-64bit?))
`((add-after 'change-directory 'disable-broken-test
- ;; This test fails on i686. Upstream developers suggest that
- ;; this test is broken on i686 and can be safely disabled:
- ;; https://github.com/openexr/openexr/issues/67#issuecomment-21169748
(lambda _
(substitute* "IlmImfTest/main.cpp"
- ((".*testOptimizedInterleavePatterns.*") ""))
- #t)))
+ ;; This test fails on i686. Upstream developers suggest
+ ;; that this test is broken on i686 and can be safely
+ ;; disabled:
+ ;; https://github.com/openexr/openexr/issues/67#issuecomment-21169748
+ ((".*testOptimizedInterleavePatterns.*") "")
+ ;; This one fails similarly on i686.
+ ((".*testCompression.*") "")))))
'()))))
(native-inputs
(list pkg-config))