aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d06dca68ea..348dd992ed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14020,19 +14020,7 @@ and also provide proven and tested solutions to common messaging problems.
AMQP is the Advanced Message Queuing Protocol, an open standard protocol for
message orientation, queuing, routing, reliability and security, for which the
RabbitMQ messaging server is the most popular implementation.")
- (license license:bsd-3)
- (properties `((python2-variant . ,(delay python2-kombu))))))
-
-(define-public python2-kombu
- (let ((kombu (package-with-python2
- (strip-python2-variant python-kombu))))
- (package/inherit kombu
- (arguments `(;; FIXME: 'TestTransport.test_del_sync' fails on python2.
- ;; It works fine on the python3 variant.
- #:tests? #f
- ,@(package-arguments kombu)))
- (native-inputs `(("python2-unittest2" ,python2-unittest2)
- ,@(package-native-inputs kombu))))))
+ (license license:bsd-3)))
(define-public python-billiard
(package