aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 453e7e689a..8145938d05 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6842,6 +6842,32 @@ interactive computing.")
(define-public python2-notebook
(package-with-python2 python-notebook))
+(define-public python-widgetsnbextension
+ (package
+ (name "python-widgetsnbextension")
+ (version "1.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "widgetsnbextension" version))
+ (sha256
+ (base32
+ "0lff2mrwrgsa1mxmwx3phl9xvy0jqfpg6khbmxy53jbq56rwy666"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-notebook" ,python-notebook)))
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-setuptools" ,python-setuptools)))
+ (home-page "http://ipython.org")
+ (synopsis "IPython HTML widgets for Jupyter")
+ (description "This package provides interactive HTML widgets for Jupyter
+notebooks.")
+ (license license:bsd-3)))
+
+(define-public python2-widgetsnbextension
+ (package-with-python2 python-widgetsnbextension))
+
(define-public python-chardet
(package
(name "python-chardet")