aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/guile.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 5dc66c1625..91a440d928 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
@@ -281,6 +281,21 @@ without requiring the source code to be rewritten.")
; when heavily loaded)
(replacement #f)))
+(define-public guile-2.2.2
+ ;; Keep it so that, when 'guix' runs on 2.2.2, 'guix pull' compiles objects
+ ;; with 2.2.2, thereby avoiding the ABI incompatibility issues described in
+ ;; <https://bugs.gnu.org/29570>.
+ (package
+ (inherit guile-2.2)
+ (version "2.2.2")
+ (source (origin
+ (inherit (package-source guile-2.2))
+ (uri (string-append "mirror://gnu/guile/guile-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "1azm25zcmxif0skxfrp11d2wc89nrzpjaann9yxdw6pvjxhs948w"))))))
+
(define-public guile-next
(deprecated-package "guile-next" guile-2.2))