aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6d3ec93a16..29792cbb21 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2913,16 +2913,17 @@ in SGML; use maths minus in text as appropriate; simple Young tableaux.")
(assoc-ref inputs "texlive-fonts-cm")
"/share/texmf-dist/fonts/source/public/cm")))
(mkdir "build")
- (every (lambda (font)
- (format #t "building font ~a\n" font)
- (invoke "mf" "-progname=mf"
- "-output-directory=build"
- (string-append "\\"
- "mode:=ljfour; "
- "mag:=1; "
- "batchmode; "
- "input " (basename font ".mf"))))
- (find-files "." "[0-9]+\\.mf$"))))
+ (for-each (lambda (font)
+ (format #t "building font ~a\n" font)
+ (invoke "mf" "-progname=mf"
+ "-output-directory=build"
+ (string-append "\\"
+ "mode:=ljfour; "
+ "mag:=1; "
+ "batchmode; "
+ "input " (basename font ".mf"))))
+ (find-files "." "[0-9]+\\.mf$"))
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))