aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/vim.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index f4416a5c5c..dffd6d96c0 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -102,6 +102,27 @@ Vim is perfect for all kinds of text editing, from composing email to editing
configuration files.")
(license license:vim)))
+(define-public xxd
+ (package (inherit vim)
+ (name "xxd")
+ (arguments
+ `(#:make-flags '("CC=gcc")
+ #:tests? #f ; there are none
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "src/xxd")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "xxd" bin)
+ #t))))))
+ (synopsis "Hexdump utility from vim")
+ (description "This package provides the Hexdump utility xxd that comes
+with the editor vim.")))
+
(define-public vim-full
(package
;; This package should share its source with Vim, but it doesn't