aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b65447113f..d0ae1006a6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15094,3 +15094,29 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"A collection of helpers and mock objects for unit tests and doc tests.")
(license license:expat)))
+
+(define-public python-pyprint
+ (package
+ (name "python-pyprint")
+ (version "0.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyPrint" version))
+ (sha256
+ (base32
+ "1qmhcz8n9rnxkj2ikcc208900yg4p9qglhw50br7carr1ca1q3ps"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-termcolor" ,python-termcolor)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "")
+ (synopsis
+ "A library providing printing facilities for python applications.")
+ (description
+ "A library providing printing facilities for python applications.")
+ (license #f)))