aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm58
1 files changed, 47 insertions, 11 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9163b5dc8a..cdb82aee8b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1382,7 +1382,7 @@ gapped, local, and paired-end alignment modes.")
("python" ,python-2)
("perl" ,perl)
("zlib" ,zlib)
- ("seqan" ,seqan)))
+ ("seqan" ,seqan-1)))
(home-page "http://ccb.jhu.edu/software/tophat/index.shtml")
(synopsis "Spliced read mapper for RNA-Seq data")
(description
@@ -5733,14 +5733,15 @@ writing files into the .sra format.")
(define-public seqan
(package
(name "seqan")
- (version "1.4.2")
+ (version "2.4.0")
(source (origin
(method url-fetch)
- (uri (string-append "http://packages.seqan.de/seqan-library/"
- "seqan-library-" version ".tar.bz2"))
+ (uri (string-append "https://github.com/seqan/seqan/releases/"
+ "download/seqan-v" version
+ "/seqan-library-" version ".tar.xz"))
(sha256
(base32
- "05s3wrrwn50f81aklfm65i4a749zag1vr8z03k21xm0pdxy47yvp"))))
+ "19a1rlxx03qy1i1iriicly68w64yjxbv24g9gdywnfmq998v35yx"))))
;; The documentation is 7.8MB and the includes are 3.6MB heavy, so it
;; makes sense to split the outputs.
(outputs '("out" "doc"))
@@ -5750,11 +5751,11 @@ writing files into the .sra format.")
#:builder
(begin
(use-modules (guix build utils))
- (let ((tar (assoc-ref %build-inputs "tar"))
- (bzip (assoc-ref %build-inputs "bzip2"))
- (out (assoc-ref %outputs "out"))
- (doc (assoc-ref %outputs "doc")))
- (setenv "PATH" (string-append tar "/bin:" bzip "/bin"))
+ (let ((tar (assoc-ref %build-inputs "tar"))
+ (xz (assoc-ref %build-inputs "xz"))
+ (out (assoc-ref %outputs "out"))
+ (doc (assoc-ref %outputs "doc")))
+ (setenv "PATH" (string-append tar "/bin:" xz "/bin"))
(invoke "tar" "xvf" (assoc-ref %build-inputs "source"))
(chdir (string-append "seqan-library-" ,version))
(copy-recursively "include" (string-append out "/include"))
@@ -5763,7 +5764,7 @@ writing files into the .sra format.")
(native-inputs
`(("source" ,source)
("tar" ,tar)
- ("bzip2" ,bzip2)))
+ ("xz" ,xz)))
(home-page "http://www.seqan.de")
(synopsis "Library for nucleotide sequence analysis")
(description
@@ -5774,6 +5775,41 @@ manipulation, online and indexed string search, efficient I/O of
bioinformatics file formats, sequence alignment, and more.")
(license license:bsd-3)))
+(define-public seqan-1
+ (package (inherit seqan)
+ (name "seqan")
+ (version "1.4.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://packages.seqan.de/seqan-library/"
+ "seqan-library-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "05s3wrrwn50f81aklfm65i4a749zag1vr8z03k21xm0pdxy47yvp"))))
+ ;; The documentation is 7.8MB and the includes are 3.6MB heavy, so it
+ ;; makes sense to split the outputs.
+ (outputs '("out" "doc"))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((tar (assoc-ref %build-inputs "tar"))
+ (bzip (assoc-ref %build-inputs "bzip2"))
+ (out (assoc-ref %outputs "out"))
+ (doc (assoc-ref %outputs "doc")))
+ (setenv "PATH" (string-append tar "/bin:" bzip "/bin"))
+ (invoke "tar" "xvf" (assoc-ref %build-inputs "source"))
+ (chdir (string-append "seqan-library-" ,version))
+ (copy-recursively "include" (string-append out "/include"))
+ (copy-recursively "share" (string-append doc "/share"))
+ #t))))
+ (native-inputs
+ `(("source" ,source)
+ ("tar" ,tar)
+ ("bzip2" ,bzip2)))))
+
(define-public seqmagick
(package
(name "seqmagick")