aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ocaml.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f6371983d3..38d581682b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3675,6 +3675,39 @@ RFC5321 and RFC6532. It handles UTF-8 email addresses and encoded-word
according RFC2047.")
(license license:expat)))
+(define-public ocaml-functoria-runtime
+ (package
+ (name "ocaml-functoria-runtime")
+ (version "4.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mirage/mirage/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "mirage" version))
+ (sha256
+ (base32
+ "09mqbffrhnklbc50gaflkwb3h1xysqqiwb84a9q1phjl038pic6r"))))
+ (build-system dune-build-system)
+ (arguments
+ '(#:package "functoria-runtime"
+ ;; TODO
+ ;; again, requires opam for tests, which needs network access.
+ ;; most other tests seem to pass.
+ #:tests? #f))
+ (propagated-inputs
+ (list ocaml-cmdliner ocaml-fmt ocaml-logs ocaml-bos ocaml-ipaddr
+ ocaml-emile ocaml-uri))
+ (native-inputs
+ (list ocaml-alcotest))
+ (home-page "https://github.com/mirage/mirage")
+ (synopsis "Runtime support library for functoria-generated code")
+ (description
+ "This is the runtime support library for code generated by functoria.")
+ (license license:isc)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")