aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am6
-rw-r--r--gnu/system/examples/vm-image.tmpl4
-rw-r--r--gnu/system/install.scm3
3 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index ac6df11c85..8df8222573 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -984,13 +984,14 @@ release: dist-with-updated-version all
-v1 --no-grafts --fallback
# Generate the ISO installation images.
for system in $(GUIX_SYSTEM_SUPPORTED_SYSTEMS) ; do \
+ GUIX_DISPLAYED_VERSION="`git describe --match=v* | sed -'es/^v//v'`" ; \
image=`$(top_builddir)/pre-inst-env \
- guix system image -t iso9660 \
+ guix system image -t iso9660 \
--label="GUIX_$${system}_$(VERSION)" \
--system=$$system --fallback \
gnu/system/install.scm` ; \
if [ ! -f "$$image" ] ; then \
- echo "failed to produce Guix installation image for $$system" >&2 ; \
+ echo "failed to produce Guix installation image for $$system" >&2 ; \
exit 1 ; \
fi ; \
cp "$$image" "$(releasedir)/$(GUIX_SYSTEM_IMAGE_BASE).$$system.iso.tmp" ; \
@@ -999,6 +1000,7 @@ release: dist-with-updated-version all
done
# Generate the VM images.
for system in $(GUIX_SYSTEM_VM_SYSTEMS) ; do \
+ GUIX_DISPLAYED_VERSION="`git describe --match=v* | sed -'es/^v//v'`" ; \
image=`$(top_builddir)/pre-inst-env \
guix system image -t qcow2 $(GUIX_SYSTEM_VM_IMAGE_FLAGS) \
--save-provenance \
diff --git a/gnu/system/examples/vm-image.tmpl b/gnu/system/examples/vm-image.tmpl
index c8449c6e95..d46a27978c 100644
--- a/gnu/system/examples/vm-image.tmpl
+++ b/gnu/system/examples/vm-image.tmpl
@@ -43,7 +43,9 @@ accounts.\x1b[0m
(keyboard-layout (keyboard-layout "us" "altgr-intl"))
;; Label for the GRUB boot menu.
- (label (string-append "GNU Guix " (package-version guix)))
+ (label (string-append "GNU Guix "
+ (or (getenv "GUIX_DISPLAYED_VERSION")
+ (package-version guix))))
(firmware '())
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index 32b9f52e04..a7b7c246bf 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -469,7 +469,8 @@ Access documentation at any time by pressing Alt-F2.\x1b[0m
(bootloader grub-bootloader)
(targets '("/dev/sda"))))
(label (string-append "GNU Guix installation "
- (package-version guix)))
+ (or (getenv "GUIX_DISPLAYED_VERSION")
+ (package-version guix))))
;; XXX: The AMD Radeon driver is reportedly broken, which makes kmscon
;; non-functional: