aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/hexedit.scm46
2 files changed, 47 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5e32d872b8..31a4d58f84 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -166,6 +166,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/gv.scm \
%D%/packages/gxmessage.scm \
%D%/packages/haskell.scm \
+ %D%/packages/hexedit.scm \
%D%/packages/hugs.scm \
%D%/packages/hurd.scm \
%D%/packages/ibus.scm \
diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
new file mode 100644
index 0000000000..d2aaec306b
--- /dev/null
+++ b/gnu/packages/hexedit.scm
@@ -0,0 +1,46 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages hexedit)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages ncurses)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public hexedit
+ (package
+ (name "hexedit")
+ (version "1.2.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://rigaux.org/"
+ name "-" version ".src.tgz"))
+ (sha256
+ (base32
+ "1mwdp1ikk64cqmagnrrps5jkn3li3n47maiqh2qc1xbp1ains4ka"))))
+ (build-system gnu-build-system)
+ (arguments '(#:tests? #f)) ; no check target
+ (inputs `(("ncurses" ,ncurses)))
+ (synopsis "View and edit files or devices in hexadecimal or ASCII")
+ (description "hexedit shows a file both in ASCII and in hexadecimal. The
+file can be a device as the file is read a piece at a time. You can modify
+the file and search through it.")
+ (home-page "http://rigaux.org/hexedit.html")
+ (license license:gpl2+)))