aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/chez.scm3
-rw-r--r--gnu/packages/patches/stex-copy-from-immutable-store.patch41
3 files changed, 45 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1b3225d075..3f9c8c02e8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1828,6 +1828,7 @@ dist_patch_DATA = \
%D%/packages/patches/slim-reset.patch \
%D%/packages/patches/slim-login.patch \
%D%/packages/patches/slim-display.patch \
+ %D%/packages/patches/stex-copy-from-immutable-store.patch \
%D%/packages/patches/syslinux-gcc10.patch \
%D%/packages/patches/syslinux-strip-gnu-property.patch \
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 043f2ae47a..812d41fc5b 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -613,6 +613,9 @@ Chez Scheme.")))
(sha256
(base32 "0n6dryv5j7cw2qmsj55wqb0ph901h83a2hl4j891ppxp0xx18nkp"))
(file-name (git-file-name name version))
+ (patches
+ ;; submitted upstream in https://github.com/dybvig/stex/pull/6
+ (search-patches "stex-copy-from-immutable-store.patch"))
(snippet
#~(for-each delete-file
'("sbin/install" "doc/stex.pdf" "doc/stex.html")))))
diff --git a/gnu/packages/patches/stex-copy-from-immutable-store.patch b/gnu/packages/patches/stex-copy-from-immutable-store.patch
new file mode 100644
index 0000000000..4562e431c1
--- /dev/null
+++ b/gnu/packages/patches/stex-copy-from-immutable-store.patch
@@ -0,0 +1,41 @@
+From 9434b4a36646c036db8de326158056aa3293fb82 Mon Sep 17 00:00:00 2001
+From: Philip McGrath <philip@philipmcgrath.com>
+Date: Thu, 28 Apr 2022 22:56:20 -0400
+Subject: [PATCH] fix read-only gifs and math directories
+
+An installed copy of stex might have all write permission bits removed,
+even for the owner of the installed files: this is the case with Guix
+package of stex, for example. If such an installation is used to
+initialize the gifs or math directories (e.g. for an out-of-source
+build), tar likewise creates them without write permissions, preventing
+subdirectories from being created later. Set the user write bit
+explicitly to avoid this problem.
+ Mf-stex
+
+Related to https://github.com/racket/racket/pull/4203
+---
+
+Submitted upstream in https://github.com/dybvig/stex/pull/6
+
+ Mf-stex | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/Mf-stex b/Mf-stex
+index 09ec6f3..11fb214 100644
+--- a/Mf-stex
++++ b/Mf-stex
+@@ -112,9 +112,11 @@ $(x).mathrun: gifs $(mathfiles)
+
+ gifs:
+ (cd $(STEXLIB); tar -cf - gifs) | tar -xpf -
++ chmod u+w gifs
+
+ math:
+ (cd $(STEXLIB); tar -cf - math) | tar -xpf -
++ chmod u+w math
+
+ $(mathfiles): $(x).hthirdrun $(figps)
+ echo -n gifs= > $(mathfiles)
+--
+2.32.0
+