aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1c2516e17a..2f932ab732 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -34800,3 +34800,30 @@ division with overflow protection
(synopsis "Idiomatic and safe LMDB wrapper.")
(description "Idiomatic and safe LMDB wrapper.")
(license license:asl2.0)))
+
+(define-public rust-mdl
+ (package
+ (name "rust-mdl")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "mdl" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xcvfg7ijf43hgp85vz022jjzsdk6lxi0krz1b9isx3gi8gniaxr"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bincode" ,rust-bincode-1)
+ ("rust-failure" ,rust-failure-0.1)
+ ("rust-lmdb" ,rust-lmdb)
+ ("rust-serde" ,rust-serde-1))))
+ (home-page "")
+ (synopsis
+ "Data model library to share app state between threads and process and persist the data in the filesystem. Implements a simple way to store structs instances in a LMDB database and other methods like BTreeMap")
+ (description
+ "Data model library to share app state between threads and process and persist the data in the filesystem. Implements a simple way to store structs instances in a LMDB database and other methods like BTreeMap")
+ (license license:gpl3)))