aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a3ffd46c81..0c80a153bf 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -34719,3 +34719,31 @@ division with overflow protection
(description
"General string search in constant space, linear time, for nonorderable alphabets.")
(license (list license:expat license:asl2.0))))
+
+(define-public rust-loggerv
+ (package
+ (name "rust-loggerv")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "loggerv" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0x6k903wpm557fkcbr5isgh4yqkkbzw4fm7hwyy61rvimqaxxn30"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-ansi-term" ,rust-ansi-term-0.12)
+ ("rust-atty" ,rust-atty-0.2)
+ ("rust-log" ,rust-log-0.4))
+ #:cargo-development-inputs
+ (("rust-clap" ,rust-clap-2))))
+ (home-page "")
+ (synopsis
+ "A simple log implementation that logs to stdout and stderr with colors")
+ (description
+ "This package provides a simple log implementation that logs to stdout and stderr with colors")
+ (license license:expat)))