aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5ed959bbdb..f9833d9f9c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33886,3 +33886,29 @@ formatters with per-field documentation generated for each structure.
(description
"This package provides the raw data needed to convert to and from HTML entities.")
(license license:expat)))
+
+(define-public rust-mach
+ (package
+ (name "rust-mach")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "mach" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yksa8lwzqh150gr4417rls1wk20asy9vhp8kq5g9n7z58xyh8xq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-rustc-std-workspace-core"
+ ,rust-rustc-std-workspace-core-1))))
+ (home-page "")
+ (synopsis
+ "A Rust interface to the user-space API of the Mach 3.0 kernel that underlies OSX.")
+ (description
+ "This package provides a Rust interface to the user-space API of the Mach 3.0 kernel that underlies OSX.")
+ (license "")))