aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index da86dedc04..7275456563 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33969,3 +33969,37 @@ formatters with per-field documentation generated for each structure.
(description
"This package provides a tiny library to efficiently search strings and byte slices for sets of ASCII characters or bytes.")
(license (list license:expat license:asl2.0))))
+
+(define-public rust-twoway
+ (package
+ (name "rust-twoway")
+ (version "0.1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "twoway" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lbf64snscr3vz71jbl6i2c8zr2ndsiqbk6316z39fj1a8mipcar"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-galil-seiferas" ,rust-galil-seiferas)
+ ("rust-jetscii" ,rust-jetscii)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-unchecked-index" ,rust-unchecked-index-0.2))
+ #:cargo-development-inputs
+ (("rust-itertools" ,rust-itertools-0.7)
+ ("rust-macro-attr" ,rust-macro-attr)
+ ("rust-newtype-derive" ,rust-newtype-derive)
+ ("rust-odds" ,rust-odds-0.2)
+ ("rust-quickcheck" ,rust-quickcheck-0.5)
+ ("rust-rand" ,rust-rand-0.7))))
+ (home-page "")
+ (synopsis
+ "Fast substring search for strings and byte strings. Optional SSE4.2 acceleration (if detected at runtime) using pcmpestri. Memchr is the only mandatory dependency. The two way algorithm is also used by rust's libstd itself, but here it is exposed both for byte strings, using memchr, and optionally using a SSE4.2 accelerated version.")
+ (description
+ "Fast substring search for strings and byte strings. Optional SSE4.2 acceleration (if detected at runtime) using pcmpestri. Memchr is the only mandatory dependency. The two way algorithm is also used by rust's libstd itself, but here it is exposed both for byte strings, using memchr, and optionally using a SSE4.2 accelerated version.")
+ (license (list license:expat license:asl2.0))))