aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/xorg.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 28ee64b96a..0aa4411ddc 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6087,7 +6087,19 @@ to answer a question. Xmessage can also exit after a specified time.")
'(#:configure-flags '("--enable-wide-chars" "--enable-load-vt-fonts"
"--enable-i18n" "--enable-doublechars"
"--enable-luit" "--enable-mini-luit")
- #:tests? #f))
+ #:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'patch-file-names
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "uxterm"
+ (("([ `\\|])(sh|sed|awk|xmessage) " _ prefix command)
+ (string-append prefix (which command) " "))
+ (("(`|\"|LANG=C )(locale) " _ prefix command)
+ (string-append prefix (which command) " "))
+ (("=xterm")
+ (string-append "=" out "/bin/xterm")))))))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs