aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-04-14 10:08:11 +0100
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:08:11 +0100
commitef4fd5ab4fee64639dcd18ead2a82aa2235661fd (patch)
tree0715f16144a8eadd915d9d17efa4e273afd8ac75 /Makefile.am
parentd69f77d59eefc1ca577d6df0cfe6d8cd46742b82 (diff)
downloaddata-service-ef4fd5ab4fee64639dcd18ead2a82aa2235661fd.tar
data-service-ef4fd5ab4fee64639dcd18ead2a82aa2235661fd.tar.gz
Add an initial test
Along with the buildsystem changes to make `make check` work.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ad9eddb..ca95abe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -54,3 +54,16 @@ SOURCES = \
guix-data-service/web/sxml.scm \
guix-data-service/web/util.scm \
guix-data-service/web/view/html.scm
+
+TEST_EXTENSIONS = .scm
+
+TESTS = \
+ tests/model-derivation.scm
+
+AM_TESTS_ENVIRONMENT = abs_top_srcdir="$(abs_top_srcdir)"
+
+SCM_LOG_DRIVER = $(top_builddir)/test-env \
+ $(GUILE) --no-auto-compile -e main \
+ $(top_srcdir)/build-aux/test-driver.scm
+
+AM_SCM_LOG_DRIVER_FLAGS = --brief=yes