aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-12-02 13:25:42 +0100
committerChristopher Baines <mail@cbaines.net>2019-12-12 20:07:22 +0000
commit8ff27eaa140c0270a441ba438474db7f70bfefd8 (patch)
treec8d9ed42f4c2116f6b068d7b28821ae38f5a9c0a
parentacf1735a0fe73622fc36852543e7fffeb24f63f9 (diff)
downloaddata-service-8ff27eaa140c0270a441ba438474db7f70bfefd8.tar
data-service-8ff27eaa140c0270a441ba438474db7f70bfefd8.tar.gz
Add a new html-utils module
To store code used for rendering HTML across multiple controllers.
-rw-r--r--Makefile.am1
-rw-r--r--guix-data-service/web/html-utils.scm35
2 files changed, 36 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e73f94b..5bf9570 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -93,6 +93,7 @@ SOURCES = \
guix-data-service/model/package-metadata.scm \
guix-data-service/model/package.scm \
guix-data-service/model/utils.scm \
+ guix-data-service/web/html-utils.scm \
guix-data-service/web/compare/controller.scm \
guix-data-service/web/compare/html.scm \
guix-data-service/web/controller.scm \
diff --git a/guix-data-service/web/html-utils.scm b/guix-data-service/web/html-utils.scm
new file mode 100644
index 0000000..e568289
--- /dev/null
+++ b/guix-data-service/web/html-utils.scm
@@ -0,0 +1,35 @@
+;;; Guix Data Service -- Information about Guix over time
+;;; Copyright © 2019 Christopher Baines <mail@cbaines.net>
+;;;
+;;; This program is free software: you can redistribute it and/or
+;;; modify it under the terms of the GNU Affero General Public License
+;;; as published by the Free Software Foundation, either version 3 of
+;;; the License, or (at your option) any later version.
+;;;
+;;; This program is distributed in the hope that it will be useful,
+;;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+;;; Affero General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU Affero General Public
+;;; License along with this program. If not, see
+;;; <http://www.gnu.org/licenses/>.
+
+(define-module (guix-data-service web html-utils)
+ #:use-module (ice-9 match)
+ #:export (sexp-div))
+
+(define (sexp-div sexp)
+ (match sexp
+ (#(val rest ...)
+ `(div (@ (style "margin-left: 1em;"))
+ "( "
+ ,val
+ " "
+ ,@(map sexp-div rest)
+ " )"))
+ ((("base16" . hash))
+ `(span (@ (style "font-family: monospace;"))
+ ,hash))
+ ((and string val)
+ val)))